# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\/video\/{2}.+)\/"
test_str = ("/video//breaking/\n\n"
"/video/breaking/\n\n"
"/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/\n\n"
"^(\\/video\\/.+)\\/$\n\n"
"^(?=.{4,15}$)\\w{2,}\\s\\w{2,}$\n\n"
"/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;\n\n"
"(?<parent>((?i)\\/video\\/(?-i)))(?<child>((?i)\\/d\\/(?-i)))\n\n"
"((?<One>\\/\\w*video\\w*\\/)\\d+)?(?<Two>xyz)(.*)\n\n"
"^.*\\b(one|two|three)\\b.*$\n\n"
"^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$\n\n"
"(?=.*?\\bmandatory\\b)\n\n"
"((?!avoid|illegal).)*$\n\n"
"^(?=.*?(\\/\\bvideo\\b\\/.+\\/))$\n\n"
"(\\/video(?=\\/)\\/(?=\\w))")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.