$re = '/^(\/video\/{2}.+)\//m';
$str = '/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\\/video\\/.+)\\/$
^(?=.{4,15}$)\\w{2,}\\s\\w{2,}$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\\/video\\/(?-i)))(?<child>((?i)\\/d\\/(?-i)))
((?<One>\\/\\w*video\\w*\\/)\\d+)?(?<Two>xyz)(.*)
^.*\\b(one|two|three)\\b.*$
^(?=.*?\\bmust-have\\b)(?=.*?\\bmandatory\\b)((?!avoid|illegal).)*$
(?=.*?\\bmandatory\\b)
((?!avoid|illegal).)*$
^(?=.*?(\\/\\bvideo\\b\\/.+\\/))$
(\\/video(?=\\/)\\/(?=\\w))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);