package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\/video\/{2}.+)\/`)
var str = `/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\/video\/.+)\/$
^(?=.{4,15}$)\w{2,}\s\w{2,}$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\/video\/(?-i)))(?<child>((?i)\/d\/(?-i)))
((?<One>\/\w*video\w*\/)\d+)?(?<Two>xyz)(.*)
^.*\b(one|two|three)\b.*$
^(?=.*?\bmust-have\b)(?=.*?\bmandatory\b)((?!avoid|illegal).)*$
(?=.*?\bmandatory\b)
((?!avoid|illegal).)*$
^(?=.*?(\/\bvideo\b\/.+\/))$
(\/video(?=\/)\/(?=\w))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}