// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[a-z0-9\_]+@[a-z]+\.[a-z]+").unwrap();
let string = "leminhung@gmail.com
hung@yahoo.com
hung@yahoo#com
@
@.
abc@abc.com
long@
khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}