import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-z0-9\\_]+@[a-z]+\\.[a-z]+";
final String string = "leminhung@gmail.com\n"
+ "hung@yahoo.com\n"
+ "hung@yahoo#com\n"
+ "@\n"
+ "@.\n"
+ "abc@abc.com\n"
+ "long@\n"
+ "khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}