re = /[a-z0-9\_]+@[a-z]+\.[a-z]+/m
str = 'leminhung@gmail.com
hung@yahoo.com
hung@yahoo#com
@
@.
abc@abc.com
long@
khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end