# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z0-9\_]+@[a-z]+\.[a-z]+"
test_str = ("leminhung@gmail.com\n"
"hung@yahoo.com\n"
"hung@yahoo#com\n"
"@\n"
"@.\n"
"abc@abc.com\n"
"long@\n"
"khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.