#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z0-9\_]+@[a-z]+\.[a-z]+"
Local $sString = "leminhung@gmail.com" & @CRLF & _
"hung@yahoo.com" & @CRLF & _
"hung@yahoo#com" & @CRLF & _
"@" & @CRLF & _
"@." & @CRLF & _
"abc@abc.com" & @CRLF & _
"long@" & @CRLF & _
"khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")