using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9\_]+@[a-z]+\.[a-z]+";
string input = @"leminhung@gmail.com
hung@yahoo.com
hung@yahoo#com
@
@.
abc@abc.com
long@
khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}