package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z0-9\_]+@[a-z]+\.[a-z]+`)
var str = `leminhung@gmail.com
hung@yahoo.com
hung@yahoo#com
@
@.
abc@abc.com
long@
khi_yeu_em_1_trieu_trai_tim_tan_vo@bsc.ok`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}