$re = '/(01\d{14})(10\d{6,})(30\d+)\+/m';
$str = '01826473610SM808+
010500981720230410DRLOT+
33098731709092010MYLOT+
0107045430049376101811023050+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);