using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(01\d{14})(10\d{6,})(30\d+)\+";
string input = @"01826473610SM808+
010500981720230410DRLOT+
33098731709092010MYLOT+
0107045430049376101811023050+";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}