use strict;
my $str = '01826473610SM808+
010500981720230410DRLOT+
33098731709092010MYLOT+
0107045430049376101811023050+';
my $regex = qr/(01\d{14})(10\d{6,})(30\d+)\+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}