package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(01\d{14})(10\d{6,})(30\d+)\+`)
var str = `01826473610SM808+
010500981720230410DRLOT+
33098731709092010MYLOT+
0107045430049376101811023050+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}