const regex = /(01\d{14})(10\d{6,})(30\d+)\+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(01\\d{14})(10\\d{6,})(30\\d+)\\+', 'gm')
const str = `01826473610SM808+
010500981720230410DRLOT+
33098731709092010MYLOT+
0107045430049376101811023050+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}