#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(01\d{14})(10\d{6,})(30\d+)\+"
Local $sString = "01826473610SM808+" & @CRLF & _
"010500981720230410DRLOT+" & @CRLF & _
"33098731709092010MYLOT+" & @CRLF & _
"0107045430049376101811023050+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")