import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(01\\d{14})(10\\d{6,})(30\\d+)\\+";
final String string = "01826473610SM808+\n"
+ "010500981720230410DRLOT+\n"
+ "33098731709092010MYLOT+\n"
+ "0107045430049376101811023050+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}