import Foundation
let pattern = #"(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\/iframe>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Custom Gida Iframe SRC grabbber <iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/JOhiWY7XmoY" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1class="gida-dummy gida-dummy-youtube" data-src=$3$4$5"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}