# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\\/iframe>)/$1class="gida-dummy gida-dummy-youtube" data-src=$3$4$5/;t' <<< "Custom Gida Iframe SRC grabbber <iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/JOhiWY7XmoY\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>"