$re = '/(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\/iframe>)/';
$str = 'Custom Gida Iframe SRC grabbber <iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/JOhiWY7XmoY" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>';
$subst = "$1class=\"gida-dummy gida-dummy-youtube\" data-src=$3$4$5";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;