# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\/iframe>)"
test_str = "Custom Gida Iframe SRC grabbber <iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/JOhiWY7XmoY\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>"
subst = "$1class=\"gida-dummy gida-dummy-youtube\" data-src=$3$4$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.