#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\/iframe>)"
Local $sString = "Custom Gida Iframe SRC grabbber <iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/JOhiWY7XmoY" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>"
Local $sSubst = "$1class="gida-dummy gida-dummy-youtube" data-src=$3$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)