import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<iframe.*?)(src=)([^ ]*?\\\".*?>)(.*?)(<\\/iframe>)";
final String string = "Custom Gida Iframe SRC grabbber <iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/JOhiWY7XmoY\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>";
final String subst = "$1class=\"gida-dummy gida-dummy-youtube\" data-src=$3$4$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}