// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(<iframe.*?)(src=)([^ ]*?\".*?>)(.*?)(<\/iframe>)"#).unwrap();
let string = "Custom Gida Iframe SRC grabbber <iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/JOhiWY7XmoY\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>";
let substitution = "$1class=\"gida-dummy gida-dummy-youtube\" data-src=$3$4$5";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}