// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/(\d+)\/(\d+)").unwrap();
let string = "http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}