const regex = /\/(\d+)\/(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(\\d+)\\\/(\\d+)', 'g')
const str = `http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}