$re = '/\/(\d+)\/(\d+)/';
$str = 'http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);