#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/(\d+)\/(\d+)"
Local $sString = "http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC" & @CRLF & _
"http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")