package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/(\d+)\/(\d+)`)
var str = `http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}