use strict;
my $str = 'http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC
http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC';
my $regex = qr/\/(\d+)\/(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}