import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(\\d+)\\/(\\d+)";
final String string = "http://floorideal.ru/katalog-produktsii-tovarov/333-iq-granit/4/10?order=DESC\n\n\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha?order=DESC\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/1/50?order=DESC\n"
+ "http://floorideal.ru/katalog-produktsii-tovarov/449-rasprodazha/4/10?order=DESC";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}