re = /([^\.!?…\n]*[\.!?…])?((?:[^\.!?…]*[\.!?…])*?)([^\.!?…\n]*)\n/
str = 'This is a sentence. This is a sentence too. So is this. And this
is a sentence, split onto different lines.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end