#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^\.!?…\n]*[\.!?…])?((?:[^\.!?…]*[\.!?…])*?)([^\.!?…\n]*)\n"
Local $sString = "This is a sentence. This is a sentence too. So is this. And this" & @CRLF & _
"is a sentence, split onto different lines."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")