import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\.!?…\\n]*[\\.!?…])?((?:[^\\.!?…]*[\\.!?…])*?)([^\\.!?…\\n]*)\\n";
final String string = "This is a sentence. This is a sentence too. So is this. And this\n"
+ "is a sentence, split onto different lines.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}