$re = '/([^\.!?…\n]*[\.!?…])?((?:[^\.!?…]*[\.!?…])*?)([^\.!?…\n]*)\n/';
$str = 'This is a sentence. This is a sentence too. So is this. And this
is a sentence, split onto different lines.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);