const regex = /([^\.!?…\n]*[\.!?…])?((?:[^\.!?…]*[\.!?…])*?)([^\.!?…\n]*)\n/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\.!?…\\n]*[\\.!?…])?((?:[^\\.!?…]*[\\.!?…])*?)([^\\.!?…\\n]*)\\n', '')
const str = `This is a sentence. This is a sentence too. So is this. And this
is a sentence, split onto different lines.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}