package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\.!?…\n]*[\.!?…])?((?:[^\.!?…]*[\.!?…])*?)([^\.!?…\n]*)\n`)
var str = `This is a sentence. This is a sentence too. So is this. And this
is a sentence, split onto different lines.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}