// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\.directive\(['"]([^'"\n]+)['"]"#).unwrap();
let string = "\"'use strict';
angular.module('testplugin', [])
.config(function () {})
.run(function() {})
.controller('TestPlugin', function ($scope) {
})
.directive('myTestPlugin', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin2222', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin3333', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin4444444', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}