package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.directive\(['"]([^'"\n]+)['"]`)
var str = `"'use strict';
angular.module('testplugin', [])
.config(function () {})
.run(function() {})
.controller('TestPlugin', function ($scope) {
})
.directive('myTestPlugin', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin2222', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin3333', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin4444444', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}