use strict;
my $str = '"\'use strict\';
angular.module(\'testplugin\', [])
.config(function () {})
.run(function() {})
.controller(\'TestPlugin\', function ($scope) {
})
.directive(\'myTestPlugin\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})
.directive(\'myTestPlugin2222\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})
.directive(\'myTestPlugin3333\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})
.directive(\'myTestPlugin4444444\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})"
';
my $regex = qr/\.directive\(['"]([^'"\n]+)['"]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}