re = /\.directive\(['"]([^'"\n]+)['"]/
str = '"\'use strict\';
angular.module(\'testplugin\', [])
.config(function () {})
.run(function() {})
.controller(\'TestPlugin\', function ($scope) {
})
.directive(\'myTestPlugin\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})
.directive(\'myTestPlugin2222\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})
.directive(\'myTestPlugin3333\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})
.directive(\'myTestPlugin4444444\', function () {
return {
restrict: \'E\',
template: \'test test test test test test...\'
};
})"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end