const regex = /\.directive\(['"]([^'"\n]+)['"]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.directive\\([\'"]([^\'"\\n]+)[\'"]', 'g')
const str = `"'use strict';
angular.module('testplugin', [])
.config(function () {})
.run(function() {})
.controller('TestPlugin', function (\$scope) {
})
.directive('myTestPlugin', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin2222', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin3333', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin4444444', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}