using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.directive\(['""]([^'""\n]+)['""]";
string input = @"""'use strict';
angular.module('testplugin', [])
.config(function () {})
.run(function() {})
.controller('TestPlugin', function ($scope) {
})
.directive('myTestPlugin', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin2222', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin3333', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})
.directive('myTestPlugin4444444', function () {
return {
restrict: 'E',
template: 'test test test test test test...'
};
})""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}