// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?")?$)"#).unwrap();
let string = "5'-2 1/2\"
5' -2 1/2\"
5' 4 2/3\"
5'-4\"
5'3 1/4\"
4\"
1/8\"
5'-3.25\"
5' 3.25\"
5'3.25\"
3.25\"
.25\"
345'-12.318\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}