#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?")?$)"
Local $sString = "5'-2 1/2"" & @CRLF & _
"5' -2 1/2"" & @CRLF & _
"5' 4 2/3"" & @CRLF & _
"5'-4"" & @CRLF & _
"5'3 1/4"" & @CRLF & _
"4"" & @CRLF & _
"1/8"" & @CRLF & _
"5'-3.25"" & @CRLF & _
"5' 3.25"" & @CRLF & _
"5'3.25"" & @CRLF & _
"3.25"" & @CRLF & _
".25"" & @CRLF & _
"345'-12.318""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")