import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?:(\\d+)')?(?:[-| ]*)(?:(\\d*(?: ?\\d+\\/\\d+)?|(?:\\d*\\.\\d+)?)?\")?$)";
final String string = "5'-2 1/2\"\n"
+ "5' -2 1/2\"\n"
+ "5' 4 2/3\"\n"
+ "5'-4\"\n"
+ "5'3 1/4\"\n"
+ "4\"\n"
+ "1/8\"\n"
+ "5'-3.25\"\n"
+ "5' 3.25\"\n"
+ "5'3.25\"\n"
+ "3.25\"\n"
+ ".25\"\n"
+ "345'-12.318\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}