const regex = /(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?")?$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?:(\\d+)\')?(?:[-| ]*)(?:(\\d*(?: ?\\d+\\\/\\d+)?|(?:\\d*\\.\\d+)?)?")?$)', 'gmi')
const str = `5'-2 1/2"
5' -2 1/2"
5' 4 2/3"
5'-4"
5'3 1/4"
4"
1/8"
5'-3.25"
5' 3.25"
5'3.25"
3.25"
.25"
345'-12.318"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}