use strict;
my $str = '5\'-2 1/2"
5\' -2 1/2"
5\' 4 2/3"
5\'-4"
5\'3 1/4"
4"
1/8"
5\'-3.25"
5\' 3.25"
5\'3.25"
3.25"
.25"
345\'-12.318"';
my $regex = qr/(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?")?$)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}