using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(?:(\d+)')?(?:[-| ]*)(?:(\d*(?: ?\d+\/\d+)?|(?:\d*\.\d+)?)?"")?$)";
string input = @"5'-2 1/2""
5' -2 1/2""
5' 4 2/3""
5'-4""
5'3 1/4""
4""
1/8""
5'-3.25""
5' 3.25""
5'3.25""
3.25""
.25""
345'-12.318""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}