import Foundation
let pattern = #"https?://(?![^" <>]*(?:jpg|png|gif))[^" <>]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://www.ex1.ir/new-img/im.png
http://www.ex2.ir/d1/d2
http://www.ex3.ir/1.gif
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}